Results 1 to 3 of 3

Thread: Thumb Warmer

  1. #1
    Join Date
    Jan 2013
    Location
    South of I-80
    Posts
    107

    Default Thumb Warmer

    I have a 2006 Artic Cat Crossfire 7 and the thumb warmer is not working. Can someone tell me if the thumb warmer has a separate fuse from the kill switch or is it all the same? Thanks!

  2. #2
    Join Date
    Dec 2009
    Location
    Waconia, MN
    Posts
    231

    Default

    Follow the wire down the bar to where the connector is. Then take it part, get out the trusty multi-meter and check the resistance in the thumb side. If it is an open circuit you have a broken wire or a failed element. IF that is not the case, switch to volts AC and test the sled side while the sled is running. should be between 8 and 12 at idle.

  3. #3
    Join Date
    Dec 2009
    Location
    The Keweenaw Peninsula
    Posts
    2,615

    Default

    Common issue, usually a failed element, time to have it replaced. -Mezz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» John Dee

» August 2020

S M T W T F S
262728293031 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 12345

» Stats

Members: 20,278
Threads: 28,629
Posts: 339,502

» Online Users: 345

7 members and 338 guests
Most users ever online was 2,946, 07-12-2019 at 01:11 AM.

» Today's Birthdays

None
Powered by vBadvanced CMPS v4.3.0