PDA

View Full Version : Indian River MI 12/9/07



power-toyz
12-11-2007, 07:26 PM
These pics were taken Sunday 12/9/07 in Indian River MI. We didn't put on many miles only about 70. The MXZ has a new mod motor in it and this was my first ride on the Pro X so most of the time was spend dialing suspensions in and checking over motors. We did manage to put in some great riding and get some pictures. The trails were awesome!

http://www.johndee.com/discuss/messages/58927/60489.jpg

http://www.johndee.com/discuss/messages/58927/60490.jpg

http://www.johndee.com/discuss/messages/58927/60491.jpg

http://www.johndee.com/discuss/messages/58927/60492.jpg

http://www.johndee.com/discuss/messages/58927/60493.jpg

http://www.johndee.com/discuss/messages/58927/60494.jpg

http://www.johndee.com/discuss/messages/58927/60495.jpg

http://www.johndee.com/discuss/messages/58927/60496.jpg

http://www.johndee.com/discuss/messages/58927/60497.jpg

http://www.johndee.com/discuss/messages/58927/60498.jpg

http://www.johndee.com/discuss/messages/58927/60499.jpg

fx4
12-11-2007, 11:53 PM
Nice pics! We rode from Alanson to Wolverine on Sunday. The connector was kind of rough, but the trails were great.

power-toyz
12-12-2007, 01:02 AM
Yes I agree with you, getting into Alanson kind of sucked but the Indian River trail system was amazing for this time of year. We went into Alanson to eat at Bob's Place right across from Spanky's Powersports.

power-toyz
12-12-2007, 01:09 AM
I put a couple of videos from the same day on YouTube. They are both of me on the Pro X, I will try and post some of the MXZ on the same jump later. Hope you all enjoy!

http://www.youtube.com/watch?v=2I7bdT3Bk80&feature=user

http://www.youtube.com/watch?v=SixilrUprZ8&NR=1

mxz500rider
12-12-2007, 07:50 AM
lil close to that tree, lol, nice vid

jeff
12-12-2007, 10:03 AM
We also road from Brutus to Gaylord through Alanson & Indian River and back on Friday and over to Habor Springs to play on the power lines on Saturday. What great early season conditions!!! Got over 200 miles in the 1.5 days of riding and not one bare or thin spot. We also saw several groomers hard at it & doing a great job! It was great!

power-toyz
12-12-2007, 10:31 AM
Yes I was a bit too close for comfort to that tree, scared me a little bit but all is well. lol

timothy
12-12-2007, 10:33 AM
Looks nice bud, how you like your new one??

yooper
12-12-2007, 10:35 AM
Nice pics and the video's are sweet. 57 more days....... The conditions look pretty good for early December.

fx4
12-12-2007, 12:41 PM
Power, That connector allways sucks! My inlaws live in Alanson and my grandpa lives in Wolverine, thats the only way to get back and forth. Still a great area to ride. Oh by the way Bob's has some great food. Maybe we will see you up there some time.FX4

power-toyz
12-12-2007, 01:10 PM
Tim, how are you buddy. I absolutely love the new sled, that motor with all the SLP work is an animal. Like my 600 stickers? By the way did you get a chance to ride your's yet. I can't wait to hear what you think.

For those who don't know, Tim bought my old sled. It was an 02 Pro X 600 and I bought an 03 700 with an SLP built motor. Here are the pictures of both, Tim's on top, mine on bottom. Both these pictures were taken at the same trailhead in Indian River MI. Kind of ironic.

http://www.johndee.com/discuss/messages/58927/60640.jpg

http://www.johndee.com/discuss/messages/58927/60641.jpg

power-toyz
12-12-2007, 01:25 PM
Just finshed putting a couple more videos on YouTube. They are both of my Dad on the MXZ X.

http://youtube.com/watch?v=ShcfJA-UylM

http://youtube.com/watch?v=lJuIyZ1d7S0

timothy
12-12-2007, 01:54 PM
Glad to hear you like your new one..looks good!! Just make sure you jet right..you dont want no burn downs!! I have not gotten out yet with mine, school has been hurting lately. I have been going over the sled completely and so far everything checks out good! Ill post some pics once I am completely done, and hopefully with some on the trail. Our family is going up north the weekend after Xmas for a week vacation, so that may be my first time out. Take it easy.

power-toyz
12-12-2007, 03:27 PM
I should be good on the Jetting. I installed an EGT guage this fall and it also has a Tempa-Flow system on it. When I rode this past weekend the EGT was reading hotter than I thought it would but the piston wash on the transfer ports looked great and the plugs were near perfect. The motor also did not feel too hot to the touch and it ran awesome so I should be good. Where are you riding for christmas? I will be up in the U.P.

timothy
12-12-2007, 03:47 PM
Sounds good. Ill be in either the northwoods of Wis. or the UP (Gwinn Mi). Where are you going to be at?

power-toyz
12-12-2007, 04:54 PM
I will be near Newberry MI

adam
12-12-2007, 07:08 PM
cool pics.. I miss that sound. Is it what you expected? Are you getting to 8150 with the new track?

power-toyz
12-12-2007, 08:25 PM
Yes it's hitting spot on. It also an absolute animal out of the hole. I have only encountered two issues with it thus far. The first issue was that the slide rails were wrecked. There was quite a bit of loose hardware in the rear suspension and there were several holes that were completely hogged out. I bought a complete rear suspension off ebay and stole the rails and some other parts from it. I also had a lot of the pieces in the rear suspension power-coated since I had it all apart anyway. My second issue is that the EGT will go above 1200 degress quite often but the plugs, piston wash, and everything else look fine so I am sort of confused at this point. It might be just the way it is. Did you ever have any issues with it overheating? Anyhow overall I love it and I can't wait to get back on it.

adam
12-12-2007, 08:58 PM
Sorry to hear about the suspension. I never had and overheat issues, The piston wash is always perfect and I never had a white plug. You can ADJ. the tempaflow a bit to faten it up and see if EGT looks better. I told you that clutch was amazing.

david
12-17-2007, 09:39 PM
Power toy- That is one clean sled!

Adam- Hows that garage of yours feel with only the switchback in it?